• PS3 Hacks, PSGroove , 02.10.2010

    Jevin has managed to port Kakaroto’s PL3 to PSGroove.

    So what exactly is PL3?

    To quote from kakaroto’s blog:

    PL3 is a new project I started in order to have a common repository of payloads that can be used by any ‘jailbreak’  implementation. I got tired of copying payloads from PSGroove, and I had some nice changes in mine that I thought the PSGroove project could benefit from, so I thought I’d create a single repository that both projects, PSFreedom and PSGroove (or any other similar projects) could use.

    You can find it in github, so don’t hesitate to submodule it and use it.

    In other words, PSJailbreak is a method to jailbreak the PS3 with a Linux based phone. jevin has ported the PSFreedom payloads to be compatible with the PSGroove jailbreak.

    You can read up more about the projects GitHub page HERE.

    If someone ones to make a easy to follow tutorial, post it in the replies and I will mirror it up here.

    Tags: , , , ,

    Discuss in Forums (37)


  • 37 Comments

    1. zetbet
      10-02-2010
      11:09 PM
      1

      compiled .hex here.

    2. Willie C.
      10-02-2010
      11:40 PM
      2

      Thanks. Works with Blackcat.

    3. Jonny8
      10-03-2010
      12:05 AM
      3

      @zetbet
      THANK U SO MUCH!

    4. Melfice
      10-03-2010
      02:44 AM
      4

      Is it possible for this to get ported to TI84 plus ?

    5. SniperSnake
      10-03-2010
      03:03 AM
      5

      does this not support backup manager? can soemone compile ome that does?

    6. advocatusdiaboli
      10-03-2010
      04:24 AM
      6

      Originally Posted by zetbet
      compiled .hex here.
      Do any of these work with Rockbox?

    7. zetbet
      10-03-2010
      04:59 AM
      7

      This is my port of PSGroove 1.1 for FW 3.15. Try and report please. If that works, I'll try with hermes' psgroove.

    8. eilex17
      10-03-2010
      05:08 AM
      8

      Zetbet please compile for my ps3 3.01!! i have ps3break atmel version, thanks !!!

    9. zetbet
      10-03-2010
      05:25 AM
      9

      Just update to 3.15, you won't loose any function. Link for 3.15 here.

    10. eilex17
      10-03-2010
      05:34 AM
      10

      thanks!! open manager works?? sorry in spanish!!

    11. junglepunk
      10-03-2010
      05:55 AM
      11

      +1 for Ti-84 port of this. I have a PS3 with 3.15 on it and would love to get it to work with JB.

    12. budzio
      10-03-2010
      07:14 AM
      12

      Originally Posted by zetbet
      This is my port of PSGroove 1.1 for FW 3.15. Try and report please. If that works, I'll try with hermes' psgroove.
      It seems to work with atavrxplain board (only LED do not change from orange to green)
      In game menu I have:
      */app_home/PS3_GAME
      *Install Package Files

      so generally it looks all right.

      EDIT:

      I've just downloaded SUDOKU homebrew ant it didn't works. I've copied AVCHD folder to root of pendrive but when trying under movies i have an error message that it cannot open movie - 80029945
      also it shows unknown usb device

    13. eilex17
      10-03-2010
      10:23 AM
      13

      Zetbet does not work ps3break 3.15,black screen help me please!!
      ************* [ - Post Merged - ] *************
      In game menu I have:
      */app_home/PS3_GAME
      *Install Package Files
      ant it didn't works backup manager and open manager...

    14. Slatscher
      10-03-2010
      10:45 AM
      14

      Compiled -all Boards- PSGroove for 3.15 Worked for me!!!

      Link:
      http://uploading.com/files/2c37a31m/v1_hex_fix.zip/

    15. eilex17
      10-03-2010
      10:47 AM
      15

      Slatscher backup manager and open manager works fine????

    16. Slatscher
      10-03-2010
      11:11 AM
      16

      I will testing now!!!! :-)

      ...

    17. eilex17
      10-03-2010
      11:26 AM
      17

      homebrew work fine in ps3break atmel, please active bd_emu for play backups!!

    18. Slatscher
      10-03-2010
      11:49 AM
      18

      That�s my Result!!! PS3 3.15 / PSGroove / Minimus AVR USB V1
      1. Only the Red LED (+Power LED) is shining on Minimus AVR USB V1!!!
      NOT work correct!!!
      2. It shows on PS3 again: An unknown USB device is connected.
      3. Open Manager 1.13 can install, copy games but I can not play Games from HDD or USB!!! Shows Game from Blu-Ray Drive not from HDD or USB after Launching!!!
      4. FTP-Server 1.1 can install but it shows me not the IP!!! Don�t Work!!!

      Thank You!!!

    19. francocangri
      10-03-2010
      12:42 PM
      19

      so if i get a ps3key or psjailbreak usb flash drive ,i can update it to jailbreak my fat ps3 that already has 3.15 fw? and wheres the download link ??

    20. zetbet
      10-03-2010
      12:54 PM
      20

      Try with this : link to psgroove 1.1 for FW 3.15

    21. eilex17
      10-03-2010
      01:28 PM
      21

      zetbet dont work , black screen!! please verify fix!!

    22. budzio
      10-03-2010
      01:39 PM
      22

      here is post from the OTHER site
      so we have some explanation...

      Originally Posted by Jevinskie
      Hello all. Sorry about the broken build last night. Apparently the port3 0x09 0x04 interface descriptors are needed, to a degree (but not as many as there originally were). I restored the port3 descriptors back to their original form.

      BD emu isn't working for some reason. It is in the PL3 payloads (as syscall 36) but Open Manger doesn't want to play my backups. Can someone w/ 3.41 test my code to see if there is a firmware version correlation?
      EDIT:
      thanks to iLLNESS there is pic2455/2550 compatible ver.
      If someone is iterested in her is link to his blog

    23. wmxp
      10-03-2010
      11:48 PM
      23

      Your 4th point Slatscher, about it not showing the IP is because you have "Internet Connection" set to disabled on your XMB. evilsperm on psx-scene has compiled a fix with bdrom support, but the LED still needs work and it doesn't have the Hermes payload for /app_home/PS3_Game

    24. BGsindikalac
      10-04-2010
      05:40 AM
      24

      So, does the compiled v1.6 psgroopic hex work on 3.41 firmware?
      ( posted on
      http://psgroopic.blogspot.com )

    25. Misterx77
      10-04-2010
      06:16 AM
      25

      can someone compile for this board

      Arduino Duemilanove

      MCU = atmega168 or atmega328p
      BOARD = ArduinoDuemilanove
      F_CLOCK = 16000000

      http://github.com/timwu/psgroove

      or can you tel me how i do it my self

      thanksss

    26. FOLEYFACTOR
      10-04-2010
      06:39 AM
      26

      Originally Posted by BGsindikalac
      So, does the compiled v1.6 psgroopic hex work on 3.41 firmware?
      ( posted on
      http://psgroopic.blogspot.com )
      Yes, when you download the file, there is three different hex files, one is for 3.01 firmware, one for 3.15 and one for 3.41, just use the correct hex and you should be sound.

    27. BGsindikalac
      10-04-2010
      10:18 AM
      27

      Thank you.

    28. budzio
      10-04-2010
      02:40 PM
      28

      Here is all hex files from firmware version 3.01/3.15/3.41 made by Evilsperm
      includes the Hermes patch as well as bdemu. Still you get the unknown USB device error but you can launch homebrew, etc... Also it is possible that LEDs could not work correctly

      http://tinyurl.com/36jypha

      Also Josh make successful compile...More on his blog

      Big Thx for both !!!!!!!!!!!!

    29. mcd1992
      10-04-2010
      09:49 PM
      29

      confirmed working on 3.15 with avr stick :D

    30. Deijavuu
      10-05-2010
      03:16 PM
      30

      Awesome news!!! Hmmm is there anyway to make this work w the HTC EVO??? Would really appreciate any help

    31. deviance159
      10-05-2010
      05:03 PM
      31

      will they be updating this to work with 3.50 do you think? Is it only a matter of time or has $ony messed that up for us? I updated before I realized this all went down :/

      -=DEV=-

    32. advocatusdiaboli
      10-05-2010
      05:36 PM
      32

      I think you should sell your 3.50 PS3 and buy one that is 3.41

    33. thefoolnz
      10-06-2010
      03:05 AM
      33

      awesome progress dude, the scene is moving forward with every step

    34. WarriorKing
      10-06-2010
      03:18 PM
      34

      You can run games with a mandatory update to a FW above 3.15?

    35. Antix
      10-07-2010
      06:12 AM
      35

      This will work with the new Maximus AVR USB v1.2?

    36. lodgechad
      10-08-2010
      10:31 AM
      36

      Anyone looking for ti_84 plus payloads for 3.15 or 3.01 check out this forum http://*******/cEqUfE

    37. OBenned
      11-10-2010
      04:16 PM
      37

      Could anybody compile this one for Maximus AVR USB v1.2 PIC18F4550 32KB