The above video goes away if you are logged in!

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    Homebrew Developer zecoxao's Avatar
    Join Date
    Oct 2011
    Posts
    1,707
    Likes
    939
    Liked 2,082 Times in 764 Posts
    Mentioned
    351 Post(s)
    Tagged
    0 Thread(s)
    Feedback Score
    0
    Downloads
    31
    Uploads
    0

    [Release] Scetool 0.3.2 - Skips 0 byte selfs:

    Since nobody has done this before i decided to do it myself. basically scetool is a much better frontend than the fail0verflow tools, and i wanted to use it on pupexplode instead of the regular tools. but Sony left some 0 byte self/sprx on their PUPs (probably links to other selfs), so i got myself into wondering how i could bypass that issue, since scetool would segfault when trying to decrypt nothing. so i just decided to make _read_buffer return NULL when the size of the file would be 0 and when decrypting the file, if it was NULL, it'd just error out instead of trying to decrypt.

    This is my own version. @deroad has another, but i figured i would make an attempt at coding myself.

    here you can see the code:
    https://github.com/zecoxao/scetool
    Last edited by hellsing9; 07-21-2014 at 08:51 PM.
    A great man once typed:
    Code:
        /* Let's be as stupid as sony here... */
        fwrite(hash + 0xC, 8, 1, fp);


  2. #2
    Senior Member tjhooker73's Avatar
    Join Date
    Jan 2011
    Location
    Texas
    Posts
    5,737
    Likes
    1,873
    Liked 1,811 Times in 1,280 Posts
    Mentioned
    394 Post(s)
    Tagged
    0 Thread(s)
    Feedback Score
    0
    Downloads
    19
    Uploads
    0
    Perhaps this should be front paged


    Sent from my iPad using Tapatalk
    Helpful Links: |MinVerCk |SKU_Models |How to downgrade |
    More: |PS3DEVWIKI |Kiosk Reverters |Jig |Progskeet |E3Flasher |Useful Tools |


  3. #3
    Homebrew Developer deroad's Avatar
    Join Date
    Jun 2010
    Location
    Outher Heaven
    Posts
    368
    Likes
    78
    Liked 381 Times in 131 Posts
    Mentioned
    133 Post(s)
    Tagged
    0 Thread(s)
    Feedback Score
    0
    Downloads
    13
    Uploads
    0
    yes, mine is at https://github.com/wargio/scetool
    Problem with PSL1GHT, click here
    My Repository (GIT)
    My Blog

  4. The Following 5 Users Like This Post:


  5. #4
    hellsing9's Avatar
    Join Date
    May 2011
    Posts
    11,191
    Likes
    5,216
    Liked 6,522 Times in 3,514 Posts
    Mentioned
    1707 Post(s)
    Tagged
    1 Thread(s)
    Feedback Score
    0
    Downloads
    11
    Uploads
    0
    If @zecoxao is ok with that, will frontpage.
    Check Blacklist of FAKE devs
    Check Whitelist of TRUSTED devs
    One thread with all DEX information published so far.
    PSdevwikiYour number 1 source, Share and expand, knowledge.
    Console ID's Market Warning thread
    PS3 Ban, CFW, Unban. How to avoid it.
    Official Tumblr n00b friendly 2K/3K/4K info.
    http://hellsing9hax.pwnz.org/ Interactive Guide to know which kind of PS3 you own.

  6. #5
    Homebrew Developer zecoxao's Avatar
    Join Date
    Oct 2011
    Posts
    1,707
    Likes
    939
    Liked 2,082 Times in 764 Posts
    Mentioned
    351 Post(s)
    Tagged
    0 Thread(s)
    Feedback Score
    0
    Downloads
    31
    Uploads
    0
    Quote Originally Posted by hellsing9 View Post
    If @zecoxao is ok with that, will frontpage.
    no need to frontpage. i'm having issues with it. it works fine in pupexplode, but i don't know why, it doesn't work when individually tested

    edit: nevermind, you're ok to post it. i'm guessing that these old firmware ros that i have here have really old keys and formats that scetool doesn't accept. most recent firmwares accept it fine
    Last edited by zecoxao; 07-20-2014 at 05:22 PM.
    A great man once typed:
    Code:
        /* Let's be as stupid as sony here... */
        fwrite(hash + 0xC, 8, 1, fp);

  7. #6
    hellsing9's Avatar
    Join Date
    May 2011
    Posts
    11,191
    Likes
    5,216
    Liked 6,522 Times in 3,514 Posts
    Mentioned
    1707 Post(s)
    Tagged
    1 Thread(s)
    Feedback Score
    0
    Downloads
    11
    Uploads
    0
    Quote Originally Posted by zecoxao View Post
    no need to frontpage. i'm having issues with it. it works fine in pupexplode, but i don't know why, it doesn't work when individually tested

    edit: nevermind, you're ok to post it. i'm guessing that these old firmware ros that i have here have really old keys and formats that scetool doesn't accept. most recent firmwares accept it fine
    So it works fine in pupexplode, but it doesn't work when individually tested?, you mean per key?.
    Check Blacklist of FAKE devs
    Check Whitelist of TRUSTED devs
    One thread with all DEX information published so far.
    PSdevwikiYour number 1 source, Share and expand, knowledge.
    Console ID's Market Warning thread
    PS3 Ban, CFW, Unban. How to avoid it.
    Official Tumblr n00b friendly 2K/3K/4K info.
    http://hellsing9hax.pwnz.org/ Interactive Guide to know which kind of PS3 you own.

  8. #7
    Homebrew Developer zecoxao's Avatar
    Join Date
    Oct 2011
    Posts
    1,707
    Likes
    939
    Liked 2,082 Times in 764 Posts
    Mentioned
    351 Post(s)
    Tagged
    0 Thread(s)
    Feedback Score
    0
    Downloads
    31
    Uploads
    0
    Quote Originally Posted by hellsing9 View Post
    So it works fine in pupexplode, but it doesn't work when individually tested?, you mean per key?.
    nah, it works, but not with really old selfs and sprx. i have no idea why.
    A great man once typed:
    Code:
        /* Let's be as stupid as sony here... */
        fwrite(hash + 0xC, 8, 1, fp);

  9. The Following 3 Users Like This Post:


  10. #8
    Member
    Join Date
    Jan 2010
    Posts
    94
    Likes
    75
    Liked 76 Times in 36 Posts
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Feedback Score
    0
    Downloads
    95
    Uploads
    1
    2 bugs I found.
    1) Meta info IV is not properly displayed.
    2) Game Spu selfs are not correctly rebuilded, like this one: rawspu_gcmdraw_spu.self
    np_klicensee=55DD480A0C0C56F84F8A2D01E03D5BDF

  11. #9
    Homebrew Developer zecoxao's Avatar
    Join Date
    Oct 2011
    Posts
    1,707
    Likes
    939
    Liked 2,082 Times in 764 Posts
    Mentioned
    351 Post(s)
    Tagged
    0 Thread(s)
    Feedback Score
    0
    Downloads
    31
    Uploads
    0
    Quote Originally Posted by mind View Post
    2 bugs I found.
    1) Meta info IV is not properly displayed.
    2) Game Spu selfs are not correctly rebuilded, like this one: rawspu_gcmdraw_spu.self
    np_klicensee=55DD480A0C0C56F84F8A2D01E03D5BDF
    that's probably not related with what i did, since i only changed util.cpp and main.cpp, and very few lines of code in them. i'm guessing those bugs already existed in other versions of scetool.
    A great man once typed:
    Code:
        /* Let's be as stupid as sony here... */
        fwrite(hash + 0xC, 8, 1, fp);

  12. #10
    Member
    Join Date
    Jan 2010
    Posts
    94
    Likes
    75
    Liked 76 Times in 36 Posts
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Feedback Score
    0
    Downloads
    95
    Uploads
    1
    Quote Originally Posted by zecoxao View Post
    that's probably not related with what i did, since i only changed util.cpp and main.cpp, and very few lines of code in them. i'm guessing those bugs already existed in other versions of scetool.
    Yes, this 2 bugs are very old
    Hope that they shold be fixed.

  13. The Following User Likes This Post:


Page 1 of 2 1 2 LastLast

Bookmarks

Bookmarks
  • Submit to Digg Digg
  • Submit to del.icio.us del.icio.us
  • Submit to StumbleUpon StumbleUpon
  • Submit to Google Google

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •